Eclipse/Plugin開発

Top / Eclipse / Plugin開発

リンク

3.1

Discouraged access

org.eclipse.jdt.internal.ui.javaeditor.JavaEditorを使おうとして失敗。
3.1RC3

Discouraged access: The type JavaEditor is not 
accessible due to restriction on required library D:
\DL\Develop\eclipse\plugins\org.eclipse.jdt.ui_3.1.0.jar

'not accessible due to restriction on required library' あたりでググると、
どうも3.1のバグ(そしてBugzillaでは放置中?)らしい。
違うファイルについてなので、違うかも?

2005-09-07追記
3.1(Release)で org.eclipse.jdt.internal.ui.javaeditor.CompilationUnitEditor を使ったところ Discouraged access といわれるが実行できた。
iconがないと言われていたので追加したが・・・それも原因だったか?
過去の自分が一番謎。

3.0

JavaEditor

  • org.eclipse.jdt.internal.ui.javaeditor.CompilationUnitEditor を使う
    • org.eclipse.jdt.internal.ui.javaeditor.JavaEditor は抽象クラス
  • extension: org.eclipse.ui.editors
    • contributorClass: org.eclipse.jdt.internal.ui.javaeditor.CompilationUnitEditorActionContributor

トップ   差分 バックアップ リロード   一覧 単語検索 最終更新   ヘルプ   最終更新のRSS
Last-modified: 2005-09-12 (月) 23:22:48 (4304d)